This article helps you fix the unsuccessful automatic removal of users in business center accounts when deprovisioned from the corporate directory of your Identity Provider (IDP) or removed from Cerby.
Cause of the Problem
The unsuccessful automatic removal of users in business center accounts may be due to one of the following scenarios:
When you remove users from the corporate directory synchronized between Cerby and your IDP, sometimes the automatic deprovisioning of users from your business center accounts fails.
Currently, Cerby doesn't support automatic deprovisioning for all business centers.
When you remove users in Cerby and don't have a corporate directory synchronized, the automatic deprovisioning doesn't occur.
If Cerby detects that some users are not automatically removed from business center accounts, we notify the Account Owner and Workspace Admin via email. We also flag the accounts and users that require action, as shown in Figure 1.
Figure 1. Flagged Accounts in the Members Tab
Solution
You must manually remove users from your business center accounts to solve this problem. We will guide you to remove the corresponding users from the Members tab of each business center account in Cerby. When you complete the process, sync the account data for each business center account in Cerby.
The removal process is different depending on the business center. In this article, we cover the following business centers:
The following sections describe the instructions for each business center.
Facebook Business Manager
To manually remove users from your Facebook Business Manager account, you must complete the following steps:
Access your Facebook Business Manager account from Cerby.
Click the Business settings ( ⚙️ ) icon located at the bottom of the left navigation drawer.
Click the People button from the Users drop-down list.
Select the corresponding user from the list.
Click the More button located at the top right.
Select the Remove from Business Account option.
Click the Remove button to confirm you want to remove access.
Go back to Cerby to sync the data of your account.
Google Ads Manager
To manually remove users from your Google Ads Manager, you must complete the following steps:
Access your Google Ads account from Cerby.
Click the Tools and Settings button in the top navigation menu.
Select the Access and security option from the Setup list.
Click the Remove access button of the corresponding user in the list.
Click the Remove access button to confirm you want to remove access.
Go back to Cerby to sync the data of your account.
Pinterest Business
To manually remove users from your Pinterest Business account, you must complete the following steps:
Access your Pinterest Business account from Cerby.
Click the down arrow ( ⬇️ ) icon located at the top-right corner of the window, next to the profile button.
Select the Business Access option.
Click the Employees button from the left menu.
Select the corresponding user from the list.
Click the Remove button located to the right under the Actions column.
Click the Remove button to confirm you want to remove access.
Go back to Cerby to sync the data of your account.
Snapchat Business Manager
To manually remove users from your Snapchat Business Manager account, you must complete the following steps:
Access your Snapchat Business Manager account from Cerby.
Click the Members button located in the left navigation drawer.
Click the right arrow ( ➡️ ) icon of the corresponding user.
Click the Remove Member button located in the top right.
Click the OK button to confirm you want to remove access.
Go back to Cerby to sync the data of your account.
TikTok Business Center
To manually remove users from your TikTok Business Center account, you must complete the following steps:
Access your TikTok Business Center account from Cerby.
Click the Members button from the Users drop-down list.
Select the corresponding user from the list.
Click the Remove ( 🗑 ) icon located in the top right.
Click the Remove button to confirm you want to remove access.
Go back to Cerby to sync the data of your account.